Exult Logo
 
Home | Download | Documentation | FAQ | Studio | Screen Shots
Development | Discussion | About Us | Letters | History | Links
 
Exult Discussion
Before posting, make sure you've read the FAQ and searched the message board for previous discussions. When reporting problems/bugs, please include details about your setup (Exult version, OS, sound and video cards).

 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 Video Jitter using 1.4
Author: Anthony (---.nycmny.fios.verizon.net)
Date:   01-05-10 07:08

Hey everyone!

I started playing Serpent Isle using Exult 1.4 on a Mac and I've noticed that the way characters move is very different than it was in Black Gate under 1.2.

In 1.2, it moved similarly to the way I remember characters moving in the original game. In 1.4 they seem to move in this more slick, 'sliding' movement, similar to the scrolling in (I think) Internet Explorer.

The problem is, there seems to be severe 'jitter' when this occurs, becoming more noticeable as the resolution is increased from the default. It's like the characters move at uneven speeds (esp while running) causing the entire screen to shake as it catches up. Using different scalars can somewhat exacerbate or alleviate this but nothing seems to actually eliminate it.

Has anyone seen this and have a workaround?

Thanks!

Reply To This Message
 
 Re: Video Jitter using 1.4
Author: Malignant Manor 
Date:   01-05-10 08:06

Disable or reduce smooth scrolling under gameplay options. I don't know how they figured most people wanted it and decided to enable by default.

Reply To This Message
 
 Re: Video Jitter using 1.4
Author: Earthquake Damage (---.iquest.net)
Date:   01-05-10 09:01

IIRC the shaking screen happened for me when I enabled smooth scrolling and infravision (whether from the cheat menu or equipping the light helm from Silver Seed). Are you wearing the helm?

Reply To This Message
 
 Re: Video Jitter using 1.4
Author: Malignant Manor 
Date:   01-05-10 11:35

Infravision, with or without smooth scrolling, is causing this. gclock->set_palette(); is being used multiple times. I can comment out line 3256 in intrinsics.cc and not have this happen until you teleport or open the cheat menu. I don't have time to really look into it atm. I thought Marzo fixed this awhile ago (or something similar).

Reply To This Message
 
 Re: Video Jitter using 1.4
Author: Anthony (72.14.228.---)
Date:   01-05-10 17:50

Ah, okay. I was using Infravision (because the torch palette always really annoyed me) and had smooth scrolling on.

I shut off smooth scrolling and while I can see that this is still occurring, the effects are *far* better than with smooth scrolling enabled. With it, the entire screen wobbles every few steps like there's an in-game earthquake. With it off, it has a small blip.

Thanks!

Reply To This Message
 
 Re: Video Jitter using 1.4
Author: Malignant Manor 
Date:   01-06-10 07:12

This also happens with invisibility.

Removing

if (!gwin->get_pal()->is_faded_out())
			gwin->get_pal()->apply(!old_invisible);

if (!gwin->get_pal()->is_faded_out())
			gwin->get_pal()->apply(!old_infravision);


seems to fix it even when clock->reset(); is used in the previously mentioned teleport and cheat menu. I don't know which case, if either, should be removed though for a proper fix.

Reply To This Message
 Go to Top  |  Go to Topic  |  Threaded View   Newer Topic  |  Older Topic 


 
 Reply To This Message
 Your Name:
 Your E-mail:
 Subject:
 Subject:
   
 
SourceForge   phorum.org
 
Problems with Exult or this webpage? Contact us.
Last modified: 24 Oct 2001(GMT)