Exult Logo
 
Home | Download | Documentation | FAQ | Studio | Screen Shots
Development | Discussion | About Us | Letters | History | Links
 
Exult Discussion
Before posting, make sure you've read the FAQ and searched the message board for previous discussions. When reporting problems/bugs, please include details about your setup (Exult version, OS, sound and video cards).

 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 

Warning: mktime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 162

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 163
 Compiler error on
Author: Lars (---.092.218.pools.vodafone-i)
Date:   06-28-17 18:07

Hi all,

i am trying to compile exult on a raspberry pi 3 with raspbian installed.

System information:
Operating System: Raspbian GNU/Linux 8 (jessie)
Kernel: Linux 4.9.28-v7+
Architecture: arm

I am using the current git HEAD.
Last commit was this: 2017-06-08 11:40 DominusExult - [master] {origin/master} {origin/HEAD} {origin/coverity_scan} The BG endgame now only shows subtitles when the Guardian speaks if speech (and audio) is enabled.

I followed along with this manual for compiling exult: https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=77185

When compiling, i get the following compiler error:

g++ -std=c++11 -DHAVE_CONFIG_H -I. -I. -I./headers -I./imagewin -I./shapes -I./server -I./data -I./gamemgr -I./objs -I./conf -I./files -I./gumps -I./audio -I./audio/midi_drivers -I./pathfinder -I./usecode -I./shapes/shapeinf -I/usr/local/include/SDL2 -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -D_REENTRANT -DXWIN -O2 -Wall -Wextra -pedantic -Wcast-qual -Wwrite-strings -Wredundant-decls -Wdisabled-optimization -fcheck-new -Wctor-dtor-privacy -Wnon-virtual-dtor -Wold-style-cast -Woverloaded-virtual -Wuseless-cast -Wtrigraphs -Wuninitialized -fstrict-aliasing -Wcast-align -Wlogical-op -Wundef -Wc++11-compat -Wno-long-long -DEXULT_DATADIR=\"/home/pi/exult/share/exult\" -MT exult.o -MD -MP -MF .deps/exult.Tpo -c -o exult.o exult.cc
In file included from /usr/local/include/SDL2/SDL_version.h:31:0,
from sdl-compat.h:4,
from exult.cc:32:
/usr/local/include/SDL2/SDL_endian.h: In function ‘Uint32 SDL_Swap32(Uint32)’:
/usr/local/include/SDL2/SDL_stdinc.h:95:71: warning: useless cast to type ‘Uint32 {aka unsigned int}’ [-Wuseless-cast]
#define SDL_static_cast(type, expression) static_cast<type>(expression)
^
/usr/local/include/SDL2/SDL_endian.h:143:12: note: in expansion of macro ‘SDL_static_cast’
return SDL_static_cast(Uint32, ((x << 24) | ((x << 8) & 0x00FF0000) |
^
exult.cc: At global scope:
exult.cc:221:43: error: ‘WrappedConnectionNumber’ declared as an ‘inline’ variable
static inline int WrappedConnectionNumber(Display *display) {
^
exult.cc:221:43: error: ‘Display’ was not declared in this scope
exult.cc:221:52: error: ‘display’ was not declared in this scope
static inline int WrappedConnectionNumber(Display *display) {
^
exult.cc:221:61: error: expected ‘,’ or ‘;’ before ‘{’ token
static inline int WrappedConnectionNumber(Display *display) {
^
exult.cc:221:19: warning: ‘WrappedConnectionNumber’ defined but not used [-Wunused-variable]
static inline int WrappedConnectionNumber(Display *display) {
^
Makefile:808: recipe for target 'exult.o' failed
make[2]: *** [exult.o] Error 1
make[2]: Leaving directory '/home/pi/exult-source/exult'
Makefile:844: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/pi/exult-source/exult'
Makefile:649: recipe for target 'all' failed
make: *** [all] Error 2

Can you please help me with this problem?

Best regards
Lars

Reply To This Message
 

Warning: mktime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 162

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 163
 Re: Compiler error on
Author: Dominus 
Date:   06-28-17 19:23

I'd start with the latest version of SDL2 or the latest mercurial of it.

--
Read the documentation and the FAQ are your friends! There is no excuse for not reading them! RTFM
Read the Rules!
We do not support Piracy/Abandonware/Warez!

Reply To This Message
 

Warning: mktime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 162

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/project-web/exult/htdocs/forum/lang/english.php on line 163
 Re: Compiler error on
Author: Lars (---.084.061.pools.vodafone-ip.de)
Date:   06-30-17 13:29

Hi Dominus,

thanks for the hint. That helped fixing it. In order to comply to the manual on https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=77185 i switched to sdl1.2 with this configure command:
./configure --prefix=/home/pi/exult --with-sdl=sdl12

So this thread can be closed as fixed.

Best regards
Lars

Reply To This Message
 Go to Top  |  Go to Topic  |  Threaded View   Newer Topic  |  Older Topic 


 
 Reply To This Message
 Your Name:
 Your E-mail:
 Subject:
 Subject:
   
 
SourceForge   phorum.org
 
Problems with Exult or this webpage? Contact us.
Last modified: 24 Oct 2001(GMT)